PHP rocks! wünscht allen Mitgliedern einen guten Rutsch ins neue Jahr 2017 !!!
Hinweis: Das Forum zieht um! Um keine Datenverluste zu haben, schalten wir zwecks Übernahme der Daten das Forum am Sonntag, den 24.04.2016 um ca. 21:00 Uhr offline und passen anschliessend die DNS-Einträge an.
www.php-rocks.de wird euch dann nach den Aktualisierungen der DNS-Server wieder wie gewohnt uneingeschränkt zur Verfügung stehen.
Danke für euer Verständnis!

Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
phpinfo wird nicht ausgelesen!
#1
Hallo,

heute bin ich auf die idee gekommen auf meinem laufenden ubuntu-system nen apache-webserver und ne mysql-datenbank zu installieren.

soweit hat auch alles geklappt, der server läuft und zeigt auch ne schnell erzeugte html-seite an , der mysql-server läuft auch.

ich habe allerdings folgendes problem: ich habe ne phpinfo.php erstellt und ins documentrootverzeichnis des servers kopiert, wenn ich versuche diese info-datei über
den apache mit nem webbrowser aufzurufen um mir die phpconfiguration etc. anzuschauen, bleibt die seite komplett leer/weiß... :-(

wie gesagt apache läuft , mehrfach neu gestartet, aber die php info will er nicht anzeigen!

PHP-Code:
<?
phpinfo
();
?>


ich kann aber z.b. phpmyadmin über den browser aufrufen und auf den mysql-server zugreifen und änderungen darüber vornehmen...

etwas confused..... hat wer ne idee?

gruß,

Helge
Antworten
#2
Hallo.

In deiner Config sind vermutlich die Short-Open-Tags deaktiviert.

- http://php.net/manual/en/ini.core.php#ini.short-open-tag

Das ist aber prinzipiell durchaus üblich/vernünftig. Nutze <?php statt <?.

PHP-Code:
<?php

phpinfo
(); 

(Den schließenden Tag benötigst du in reinen PHP-Dateien nicht.)
Antworten
#3
Hallo,

danke für deinen tipp ich schau mir  mal meine php.ini an :-) .

gruß,

Helge
Antworten
#4
Hallo,

Wie mermshaus schon sagte, ist das nicht unüblich und zumeist sogar sinnvoll.
Lass in diesem Fall lieber die Finger von der php.ini und nutze das bereits vorgegebene <?php-OpenTag.

Gruß Arne
Antworten
#5
Hallo,

leider hat letztendlich nur die abänderung der php.ini zum ziel geführt,  aber jetzt wird die phpinfo ausgelesen und im browser angezeigt :-)

da die server nur im homenetz laufen und keinem produktivsystem angehören, denke ich das die abänderung sicherheitstechnisch nicht so
gravierend ist. Ich habe jetzt aber ein gut funktionierendes übungsfeld geschaffen :-)

danke nochmal für den tip,

gruß,

Helge
Antworten
#6
Wenn es mit <?php nicht funktioniert hat, ist da aber was im Argen...
Antworten
#7
ok....

hast du ne idee woran das liegen könnte? für mich siehts erstmal so aus als würde alles funzen :-)

gibt es iwelche tests die mal machen kann/soll, bzw. noch iwas überprüfen? :-)

gruß,

Helge
Antworten
#8
Ich bin mir nicht sicher, ob ihr nicht aneinander vorbeiredet. Eine PHP-Datei mit diesem Inhalt…

PHP-Code:
<?php

phpinfo
(); 

…wird unter allen Umständen ordnungsgemäß funktionieren, wenn PHP-Code überhaupt ausgeführt werden kann.
Antworten
#9
Genau davon rede ich ;-)

Ich beziehe mich darauf, dass das scheinbar bei Helge nicht funktioniert hat und er die ShortOpen-Tags in der php.ini aktiviert hat:
HelgeHH schrieb:leider hat letztendlich nur die abänderung der php.ini zum ziel geführt,
Antworten
#10
Hallo,

ich habe in der php.ini short-tags jetzt wieder auf off gesetzt, alles funzt so wie es soll, keine ahnung was ich falsch gemacht hatte??

jedenfalls habe ich nochmal alles ausgetest und mir wird die phpinfo normal ausgelesen und angezeigt........

Wie gesagt keine ahnung was das problem war, die Webseite bleibt nicht mehr weiss und leer, das ist die hauptsache :-)


gruß,

Helge
Antworten


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  PHPMailer Pfad wird nicht gefunden Gebby 5 2.856 23.08.2022, 21:07
Letzter Beitrag: Arne Drews
  Session Files werden nicht beschrieben Till 5 13.083 26.05.2017, 09:16
Letzter Beitrag: Arne Drews

Gehe zu: